Back to overview
Downtime
Main website is unavailable
Oct 12 at 11:00pm UTC
Affected services
cicku.me
Resolved
Nov 08 at 05:47am UTC
The website has been restored
Affected services
Created
Oct 12 at 11:00pm UTC
The main website is in an extended outage due to internal testing, the setup is independent from mirror and other services.
Affected services